Home > Technical Articles > Program Requirements


Windows Versions Supported:
  • Microsoft Windows Vista, Windows XP, Windows 7, Windows 8, Windows 10 (32-bit or 64-bit).
  • Supports Windows XP Home and Professional versions, including 32-bit and 64-bit.
  • Supports Windows Vista Home, Business and Ultimate versions, including 32-bit and 64-bit
  • Supports Windows 7 Home, Professional and Ultimate versions, including 32-bit and 64-bit
  • Supports Windows 8 desktop versions, including 32-bit and 64-bit
  • Supports Windows 10 desktop versions, including 32-bit and 64-bit
Not Supported:
  • Portuguese Windows is not supported.
  • EssentialFax will not install or run on some "server" operating systems. If in doubt - try before you buy.
  • EssentialFax will not run in a virtual machine, such as VirtualPC, VirtualBox, VMWare or Parallels.
  • Windows RT (aka Windows 8 tablet)
Hardware requirements: